Your server is running PHP version 5.2.3 but WordPress 3.9.1 requires at least 5.2.4.